PDA

View Full Version : Internal (Page-to-Page) Link Problem



Richie-Rich
10-22-2006, 06:55 AM
I have two pages, the first linking to the second. Simple enough. But when I "preview in browser", it doesn't work.

The name of my site is www.mortgagekiller.com (http://www.mortgagekiller.com) and the 2nd page's "name" is 'HowToThrive.bvp', so I (initially) set up the link from my first page to go to www.mortgagekiller.com/HowToThrive.html (http://www.mortgagekiller.com/HowToThrive.html). I previewed it but it didn't work.

I then changed it to www.mortgagekiller.com/HowToThrive.bvp (http://www.mortgagekiller.com/HowToThrive.bvp), but that didn't work either.

I realize the pages aren't published yet, but i thought "preview in browser" somehow simulated what the web site would look like when it was published.

If that's right, what am I doing wrong?

If that's not right (if "preview" doesn't simulate that way and requires the site to be published), how do I test it - preview it - prior to publishing?

Bethers
10-22-2006, 06:57 AM
Links can't work in preview if the page they are linking to isn't published as the page doesn't exist in the www world until published.

You just have to make sure the links are right.

Richie-Rich
10-22-2006, 07:12 AM
Beth -

Thanks. But would you mind answering my other, related questions as well?

1) Is the correct naming convention www.mortgagekiller.net/HowTo.bvp (http://www.mortgagekiller.net/HowTo.bvp) or www.mortgagekiller.net/HowTo.html (http://www.mortgagekiller.net/HowTo.html)?

2) Is there any way of testing my web site for links and the like, prior to publishing?

Thanks again!

navaldesign
10-22-2006, 08:13 AM
1) www.mortgagekiller.net/HowTo.html (http://www.mortgagekiller.net/HowTo.html) is the correct one

2) There is no way of testing your links before publishing.