PDA

View Full Version : Please HELP - formmaker install -Critical!!!



verushka
10-26-2006, 03:05 PM
Hi,
is there anyone that can tell me why after I fill out all the correct info into the installation form and click Install it comes back with
file db.conf.php is not writable
What does it mean and how can I correct it? After about 100 tries I am about to smash my computer and go walkabout.

navaldesign
10-26-2006, 07:57 PM
You probably have wrong permissions in your FMP folder. It usually needs to be set to 755. Check it.

verushka
10-30-2006, 02:23 PM
Hi,
thanks for reply. Our permission is always set to 755 and it still does not work. When I go back to cpanel and check the fmp folder it shows 755 but when I click the folder to check the permission it's back to 777. And it keeps happening over and over. Don't know what I am doing wrong. And my formmaker is still not working.

navaldesign
10-30-2006, 02:44 PM
When you chechkit in CP, it shows the correct value. Only when you click on change permissions, the table that shows up is set to 777, but this doesn't mean it is on 777. It's only the permissions table that starts with 777 when it opens. Check the permissions of the subfolders. One more question: which server are you on ?

verushka
11-01-2006, 08:09 AM
Hi, thanks for the explanation. My server is Mozilla Firefox. My formmaker still showing the same message. The relevant folders are all showing 755. Would my server be the problem and if so please dvice. Thank you.

navaldesign
11-01-2006, 08:39 AM
No, i mean your VH server: what is your site IP ?

Vasili
11-01-2006, 08:41 AM
< As a ranking Forum Moderator, General Naval has the ability to look into your account for a solution, and that is why he asked which VodaHost Server you are hosted on..... Mozilla is a web browser, not a server! >

Example: If you publish to server 74.52.42.242 (which is also VH NS 13 & 14), you would be on Voda8. :: See the list HERE (http://www.vodahost.com/login.htm)



EDIT/ADD: Sorry, General....took me too long to type! Didn't mean to butt in.....

navaldesign
11-01-2006, 09:00 AM
No worries Vasili, any help to other members is appreciated!

verushka
11-01-2006, 09:01 AM
Hi,
thanks. I am on 74.52.103.210 or voda10

navaldesign
11-01-2006, 12:41 PM
I still beleive it is a permission issue, but i cannot be sure without access to your account. You can submit a support ticket, or use myform (http://www.navaldesign.info/feedback13.html) to send me your login details so i can have an inside look.

Robert
11-01-2006, 05:56 PM
I had similar issues like this with FMP and Naval is probably right about it being a permission issue. I had a subfolder within a subfolder of FMP that didnt get set to 755 when I first ftp'd the FMP folder to my site prior to install. I'd like to know what stage you are at with FMP that is causing a snag. Is this after you uploaded the whole FMP folder to your site, set permission of the whole directory to 755, and then clicked the file "install.php"--one thing you could try:

1. Delete the FMP folder you uploaded to your site - "/public_html/fmp"

Also, Delete the unzipped fmp folder on your computer prepare for the next step. (For the next step I would suggest deleting the original zipped copy you initially downloaded to your computer, but not neccessary.

2. Download the zipped FMP file OR locate it on your computer. DO NOT UNZIP OR EXTRACT FILES YET.

***Windows XP has some of the strangest moments when it comes to file handling...so I do this before unzipping ANY file downloaded to my computer BEFORE I do anything with it:

3. "Right-click" the zipped fmp file,"fmp.zip", and select "Properties", If you see the notice at the bottom of the properties dialog --"This File is from another computer, it has been blocked....blah blah" click the "UNBLOCK" button to the right. (also I go to the advanced button and uncheck the "ready for archiving..." and uncheck the "index this ...blah blah" --click "Apply" then "Ok"

*I see this as simply allowing the extraction/unzipping process to occur while keeping my computer from applying file handling settings associated with my user account. Now:

3. Unzip/Extract All..whichever method you use, unzipping all the files into its new "fmp" folder, open up your BlueFTP or your ftp of choice and Connect to your site. Now "Right-Click" the fmp folder again, select "Properties" and click "advanced", UNCHECK the "this file is ready for archiving..." --click Apply, then "OK"

When connected to your site:
In BlueFTP: click the folder icon next to "public_html/" --Click and drag the fmp folder from your window to the blueFTP window. Now you can change the permission of the folder here to 755 but some files wouldnt change this way. Use cpAnel to change them it worked. If you MOVE fmp to site, even better. By following the steps above and clicking the "MOVE FILES TO" button , a problem I had with a mysterious permission problem that wouldn't allow the forms generated by itself for me to put on my site to work properly.

Phew!!!!! developer brain needs resting...Is this the longest post at Voda?

ebomb
11-03-2006, 02:17 AM
Hi Everyone,

I really need help. I completed the steps to create a form, then a thank you page, using php. But now everytime I click submit on my signup page, instead of sending me the info and redirecting the customer to the thankyou page, it brings them to a blank page with this on it:

Parse error: syntax error, unexpected '=' in /home/cyessrpc/public_html/action.php on line 134

If you need to see the sign-up page it's at http://www.ebombcoaching.com/signup.html

Thank you in advance!
Ebomb

verushka
11-07-2006, 10:06 AM
Hi Robert,
thank you for your effort to help me and for your step by step instructions. I'll try it, but I think it will be much easier for me to let Naval to have a look into my account. He's an expert and I am just a "newbie". Thanks anyway. Have nice day.
Vera
www.netbizcorp.com

aclips
11-07-2006, 09:21 PM
Trought your FTP program you may just set up the command to 777, if you have Cpanel you can do it also

Robert
11-09-2006, 06:16 AM
Hi Everyone,

I really need help. I completed the steps to create a form, then a thank you page, using php. But now everytime I click submit on my signup page, instead of sending me the info and redirecting the customer to the thankyou page, it brings them to a blank page with this on it:

Parse error: syntax error, unexpected '=' in /home/cyessrpc/public_html/action.php on line 134

If you need to see the sign-up page it's at http://www.ebombcoaching.com/signup.html

Thank you in advance!
Ebomb
------
This thread is for FormMakerPro intallation problems so heads up if your post gets moved, ok.

Is this a form you created yourself? or using FormMakerPro?

--the error says that line 134 in you action.php file.... there is an unexpected "="

My first guess is the "ACTION" for your form is incorrect. You put:

"ACTION=goto:action.php"

Change this to: "action.php"

I do wonder, if this file is located in another directory or subdirectory try setting your ACTION to the actual url :

ACTION=http://ebombcoaching.com/action.php

navaldesign
11-09-2006, 07:12 AM
http://www.vodahost.com/vodatalk/forms/9350-bluevoda-forms-tutorial-part-2-a.html#post92081

posts #21 - 22 . Ofcourse the action needs to be corrected.

Ebomb is posting all around about this, and not even looking for the answers to his posts.

The form is made in BV