PDA

View Full Version : First form arrives fine, second one has probs



Four Paws
05-02-2007, 04:03 AM
We have a dog boarding business, each client has to fill out an enrollment form for their dog. If they have 2 or more dogs the successive forms come emailed without the questions, just T1 headings.......any help greatly apprecitated!

http://www.fourpawsplay.com/enrollment.html

Andy128
05-02-2007, 04:16 AM
Can you post the php code that you use to process the form?

Thanks-

Andy

Four Paws
05-03-2007, 05:12 PM
Hi Andy, thanks for responding, not sure where the PHP code is but under the properties page I found this under "action" thankyou.php After hitting the submit button a Thank You page comes up. Please let me know if you need more info and feel free to hit the submit if you need to........just one of the little things that drives me nuts!

Rob
www.fourpawsplay.com (http://www.fourpawsplay.com)

navaldesign
05-03-2007, 05:41 PM
There are some problems on your form, like alignment, layout etc, but none of these would create a problem like the one you are mentioning.
T1, T2 etc are the default field names that BV assigned the fields (up to v.8 . Neither can it be an issue regarding the script. Is the problem presented with actual client submissions, or is it a problem with your own test submissions ?

Also, when they try to submit for the second time, do they go through the same menubar, or do you have another form (forgotten) and they submit through this second form ?

Four Paws
05-03-2007, 10:39 PM
Problem is with actual client submissions and they use the same menu bar for the next form

navaldesign
05-04-2007, 05:33 AM
Actually, theu DON'T use the same menu bar.

Your Thank you page menubar is different from your Index page menubar.

Ok, i have found out what you have done.

You have TWO enrollment forms:
one called "enrollment.html" which is the correct one, and is also the one that you get to from the menubar in the index page.

Then you have a second one, "enrollment_form.html" which is the one giving you the problems.

The problem arises because in the thank you page menubar, the link for "Enrollment" send the visitors to this second form which has never been setup correctly (it has the fields named T1, that's why you received them like that)

Four Paws
05-05-2007, 04:21 PM
Awesome! Thanks so much......can you refresh my memory on how I name the fields so that T1 doesn't show? Also, do I need to change all the menu bars so that Enrollment reads enrollment.html?

navaldesign
05-05-2007, 09:01 PM
Awesome! Thanks so much......can you refresh my memory on how I name the fields so that T1 doesn't show? Also, do I need to change all the menu bars so that Enrollment reads enrollment.html?

You don't need to rename anything, you just need to leave the second form out of your menubar (eventually you can also delete it). Simply change the links to the thank you page menubar, from "enrollment_form.html" to simply "enrollment.html". I have NOT checked the links in your other pages, but YOU should do it, just to avoid them submitting through the wrong form.