PDA

View Full Version : i do not recieve emails



gtberryhill
05-06-2007, 08:44 PM
Hello, I am posting for the first time because I have been able to eventually figure out every other snag i've had in creating my website but I cannot receive the emails from my forms. My site is www.gtberryhill.com (http://www.gtberryhill.com) on both my new nome search and my contact us page I just don't get the emails when people submit the forms, I have tried everything I could find in the forums but it still eludes me can someone look at my source and help me out.

Andy128
05-06-2007, 09:34 PM
Well- First off, I am not familiar with Java Script so I am a little lost as to how you incorportate that into the php processing.

With that aside- you have set the form to use action.php to process the form yet you have the php code to processs within the contact us page?

What have you in the action.php page?

Also- what set of instructions/tutorials have you used to for this?

Andy

navaldesign
05-06-2007, 09:58 PM
You have used "action.php" as your action page, but the script is pasted in your form page . I can see it because the page is html and not php. Please conirm that you have also pasted it in the "action.php" page.

Andy, this is the standard Javascript validation script that BV9 creates. The script is from the updated Form Tutorial Part 1

Andy128
05-07-2007, 02:47 AM
Thanks Naval- I shall look into it straight away.

Andy

gtberryhill
05-07-2007, 10:25 AM
I used the form making tutorials. So I have to have the same script in both pages, but make the action page php? do I make the form page PHP as well? . because when the form is filled out it goes to the action page but it does not email. Thanks for your responses

navaldesign
05-07-2007, 10:35 AM
No. The form page can be html. The action page needs to be php. The script goes ONLY in the action page. If you don't receive the mails, you must have done something wrong. Post here the script that you have used. Make sure you have put your own email address in the script, and also make sure that the mails have not ended up in your spam folder.

gtberryhill
05-07-2007, 02:22 PM
YES. Thank you, I had put the script in the form page not the action page, now it works. Thanks so much