PDA

View Full Version : form assistance required



jaykay
05-27-2007, 08:31 AM
Sorry about this, but something has gone wrong with my form. The submit button works in as much as the thank you page comes up but I don't receive and email.

http://www.pxmcyprus.com/contact_us.html
Thanks in advance
Julie

navaldesign
05-27-2007, 12:07 PM
I tested your form, and got the thank you page. Did it work before ? were you receiving the emails ?

jaykay
05-27-2007, 07:25 PM
Yes and Yes

navaldesign
05-28-2007, 04:58 AM
I can only suggest that you post here the code of your thankyou page so we can have a look.

jaykay
05-28-2007, 06:53 AM
Thanks Naval design, here's the code.
I did put a new comments box on the contact us page, so I'm guessing that I have altered something by mistake.

Much appreciate your help.

<?PHP
$mailto = "pxmcyprus@cytanet.com";
$email = $HTTP_POST_VARS[email];
if ($email == "") {
$email = $mailto;
}
$mailsubj = "Contact Form Submission";
$mailhead = "From: $email\n";
reset ($HTTP_POST_VARS);
$mailbody = "Values submitted from web site form :\n";
while (list ($key, $val) = each ($HTTP_POST_VARS))
{
if ($key!="submit")
{
$mailbody .= "$key : $val\n";
}
}
mail($mailto, $mailsubj, $mailbody, $mailhead);
?>

navaldesign
05-28-2007, 06:59 AM
Both your form and your script look ok, and the thank you page comes up fine. Unless you have made some mistake in pasting the script in the thank you page, the only other possible explanation could be your ISP blocking the emails or your email address being wrong.
Please poste the code of the ENTIRE thank you page

jaykay
05-28-2007, 12:53 PM
Hi Navaldesign
I now appear to be receiving emails !!! However this is one of them, is this how it should be?
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

pxmcyprus@cytanet.com.cy (pxmcyprus@cytanet.com.cy)
(generated from hdihgel@pxmcyprus.com (hdihgel@pxmcyprus.com))
SMTP error from remote mail server after RCPT TO:<pxmcyprus@cytanet.com.cy (pxmcyprus@cytanet.com.cy)>:
host mail-relay.cytanet.com.cy [195.14.130.157]:
450 4.1.8 <hdihgel@voda15.vodahost.com (hdihgel@voda15.vodahost.com)>: Sender address rejected:
Domain not found: retry timeout exceeded

------ This is a copy of the message, including all the headers. ------

Return-path: <hdihgel@voda15.vodahost.com (hdihgel@voda15.vodahost.com)>
Received: from hdihgel by voda15.vodahost.com with local (Exim 4.63)
(envelope-from <hdihgel@voda15.vodahost.com (hdihgel@voda15.vodahost.com)>)
id 1HsdlM-0001w4-Jj
for hdihgel@pxmcyprus.com (hdihgel@pxmcyprus.com); Mon, 28 May 2007 06:51:48 -0500
To: hdihgel@pxmcyprus.com (hdihgel@pxmcyprus.com)
Subject: Contact Form Submission
From: kemp.cyprus******.com (kemp.cyprus******.com)
Message-Id: <E1HsdlM-0001w4-Jj@voda15.vodahost.com (E1HsdlM-0001w4-Jj@voda15.vodahost.com)>
Date: Mon, 28 May 2007 06:51:48 -0500


Values submitted from web site form :
name : It\'s only me
email : kemp.cyprus******.com (kemp.cyprus******.com)
tel :
Comments : Can you phone me please?


__________ NOD32 2293 (20070527) Information __________

This message was checked by NOD32 antivirus system.
http://www.eset.com (http://www.eset.com/)

navaldesign
05-28-2007, 06:49 PM
No, this is not what you should have received. This is the error message from the server because the mail has failed. The script works, but the the mail has been rejected.

Try changing the email address to something else.


Please note that you have pxmcyprus@cytanet.com in your script and then the error message reports pxmcyprus@cytanet.com.cy (pxmcyprus@cytanet.com.cy) . Which one is correct ?

jaykay
05-30-2007, 05:40 AM
Hi Navaldesign
I'm afraid I'm completely lost now. When I first signed up I already had an email address ready (pxmcyprus@cytanet.com.cy) Then bluevoda gave me (under account email address) hdihgel@pxmcyprus.com In CPanel I tried to forward any mail to the email I already had set up.
So, although the sumbit button and thank you page are working, the emails I get always have the error message as above #7
Also, on this page http://www.pxmcyprus.com/Plans.html my 'click here to view prices' doesn't work and I can't, for the life of me work out why.
Any help appreciated, although please feel free to direct me to anywhere or anyone that I should be asking.
Thanks again.
Julie

navaldesign
05-30-2007, 05:57 AM
Your View Prices doesn't work because the link URL is wrong. You have placed in the URL field "C:\Documents and Settings\Julia\My Documents\BlueVoda\Prices.html" instead of http://www.pxmcyprus.com/Prices.html

probably because you have clicked on the "Browse for a file". Edit it and it will work.

About the form: do not confuse the redirection that you tried to setup in your CP with the form script. These are tow entirely different issues.

In the script, use your old, proven email address and see what is going on. If the script sends, but you don't receive the mail (you only get the error message) then it is either a typing mistake, or your ISP (cytanet.com.cy) is blocking the mail for some reason. You must first find out what your problem is in order to solve this.