PDA

View Full Version : Form Assistance Required



Herowe
07-08-2007, 02:04 AM
My web site is www.new-generic-******.com (http://www.new-generic-******.com) ID#15576..I have read most of the forums relating to this problem, however I know am doing some thing simple wrong..I have followed the tutorials to the T...Tried using advice to others and am still stuck.

It just does not work..Form properties is correct...yes I installed action.php. Placed all into one large form area.including submit button.

I am not using Outlook Express for my email. Does that cause a problem?

<?PHP
$mailto = "mdventures@netzero.com";
$email = $HTTP_POST_VARS['email'];
if ($email == "") {
$email = $mailto
}
$mailsubj = "Comments";
$mailhead = "From: $email\n";
reset ($HTTP_POST_VARS);
$mailbody = "Thank you for contacting us.Will reply soon :\n";
while (list ($key, $val) = each ($HTTP_POST_VARS))
{

Somebody check the above please this is getting too long..Thanks Dave

Watdaflip
07-08-2007, 02:14 AM
Your contact for does not have an action. You may have made the action page but the form doesn't know that.

Also if the php code you have above is everything that is in the php script (your action page) then it is not going to work. What you posted it incomplete.

Oh and your submit button is no connected to the form. It is outside of the form field

navaldesign
07-08-2007, 06:32 AM
Also the encoding type is wrong (should be multipart/form data instead of text/plain) and the Name field has the default value of "Editbox1". The text area also is unnamed and out of the form.

Herowe
07-08-2007, 05:27 PM
Thanks for the help...I deleted both the contact form and action page and started over fresh....Made sure the form was large enough to cover everything. redid the action page also. Published.....Tried it...it sent two emails to mdventures....from mdventures.....1st one said Value submittted from web page....2nd said 250 words or less....No message, and no email address or name. I assume the problem is with the html...Any ideas? It has refused to send any more no matter what I do. Thanks Dave

Watdaflip
07-08-2007, 06:24 PM
Did you change the enctype to multipart/form like naval said?

navaldesign
07-08-2007, 08:25 PM
Are we talking about the "contact.html" ? If yes, NONE of the above points have been fixed. Did you republishe the fixed pages ?

Herowe
07-08-2007, 11:04 PM
Thanks again....answer is yes to all questions..form properties--name--form1---action.php---Post----multipart/formdata--email is called email in editbox properties..text area name textarea1.

Maybe this will help


<meta name="GENERATOR" content="Created by BlueVoda">
<style type="text/css">
div#container
{
width: 800px;
position: relative;
margin-top: 0px;
margin-left: auto;
margin-right: auto;
text-align: left;
}
body
{
text-align: center;
margin: 0;
}
</style>
</head>
<body bgcolor="#FFFFFF" text="#000000">
<?PHP
$mailto = "mdventures@netzero.com";
$email = $HTTP_POST_VARS['email'];
if ($email == "") {
$email = $mailto;
}
$mailsubj = "mdventures@netzero.com";
$mailhead = "From: $email\n";
reset ($HTTP_POST_VARS);
$mailbody = "250 worda or less :\n";
while (list ($key, $val) = each ($HTTP_POST_VARS)) {
if ($key!="submit") {
$mailbody .= "$key : $val\n";
}
} mail($mailto, $mailsubj, $mailbody, $mailhead);
?>

<div id="container">
<div id="bv_" style="position:absolute;left:297px;top:149px;width:362px ;height:103px;z-index:0" align="left">
<font style="font-size:19px" color="#000000" face="Arial"><b>Thank You for contacting us.<br>
<br>
You will hear from us within 24 hrs<a href="http://www.new-generic-cialos.com/action.php" target="_blank"><br>
<br>
</a></b></font></div>
<div id="bv_" style="position:absolute;left:34px;top:58px;width:150px;h eight:150px;z-index:1" align="center">
<table border="0" cellpadding="0" cellspacing="0" id="NavigationBar1">
<tr>
<td align="left" valign="top" width="124" height="30"><a href=""><img id="bv01045" src="bv01045.gif" alt="" align="top" border="0" width="124" height="30"></a></td>
</tr>
<tr><td height="4"></td></tr><tr>
<td align="left" valign="top" width="124" height="30"><a href=""><img id="bv01046" src="bv01046.gif" alt="" align="top" border="0" width="124" height="30"></a></td>
</tr>
<tr><td height="4"></td></tr><tr>
<td align="left" valign="top" width="124" height="30"><a href=""><img id="bv01047" src="bv01047.gif" alt="" align="top" border="0" width="124" height="30"></a></td>
</tr>
<tr><td height="4"></td></tr><tr>
<td align="left" valign="top" width="124" height="30"><a href=""><img id="bv01048" src="bv01048.gif" alt="" align="top" border="0" width="124" hek="30"></a></td>
</tr>
</table>
</div>
</div>
</body>
</html>

Thanks to all. Dave

Herowe
07-08-2007, 11:25 PM
Me again...was checking html on contact page and discovered spelling error in an address, plus some other information that should not be in there. I can not get any html down to the edit area.(the part that i want to delete or correct the spelling.)

How do I delete every thing and start over new?
Thanks Dave

navaldesign
07-09-2007, 05:07 AM
Is this the "action" page code ? if yes, then it is correct, though.

However, your FORM page is still the same. Have a look at the source code in your browser to see for yourself that the mistakes in the form have NOT been edited.

Maybe you have published the "contact" page as php ? because i also find a "contact.php" page in your site (with yet other problems)

Make sure you edited the "contact" page in BV, publish it as html. Then open the above code page, save it as "action" and publish it as php.

Herowe
07-14-2007, 10:57 PM
It's me again with a big smile on my face.

I finally got into cpanel, and deleted all the things that were not required.

Built a new contact us page and a new action.php page, and now it looks like every thing is working good, just the way it should...

Thanks to all that helped out.

Dave