PDA

View Full Version : Soholaunch Install Problem



Bruce Hewitt
07-13-2007, 02:51 PM
Hi All!

I get the following error message when I try to access the admin area of my Soho installation:
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@webbrok.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request

I reset my account and installed it in my main directory to no avail.

Any suggestions?
Does it take a while to be up and running?

Thanks in advance!
Bruce

Karen Mac
07-13-2007, 05:50 PM
Bruce

It doesnt seem to be installed properly for some reason. You can try uninstalling and reinstall or you can go to soho and download the latest configuration, and upload it to the main directory, then go to the browser window and type in
www.webbrok.com/installsoholaunch.php (http://www.webbrok.com/installsoholaunch.php)

Or whatever that file is called.. but i think thats it.. and see if that will over write and update some misconfigured file in there. Make sure to delete that file when you are done!!!

Make sure also that your permission is set to 755 for that folder so that it can write to it. 777 will produce errors as well. Also make sure you are installing to the correct domain.

Karen

Bruce Hewitt
07-13-2007, 06:36 PM
Thanks Karen.
Will give that a crack first thing in the morning

Karen Mac
07-14-2007, 02:43 AM
If you do the manual install, you will need to know or go to mysql and create a user name and password for the sope1 data base. Remember that it will be your login name_sope1 as database and the user will be, loginname_databaseusername. Im so used to doing it, i forget to tell people to do it.

Karen

Bruce Hewitt
07-14-2007, 01:25 PM
Hi Karen

Thanks for the help.

Just downloaded the files from soho.
Followed the instructions and upoloaded the installshoholaunch.php to my public_html folder on my main site.
Set the permissions to 755.
On trying to access the file as per instructions for the manual install I get the same error!

Karen Mac
07-14-2007, 06:31 PM
Bruce

Is this a main domain or are you setting it up in a subdomain? Id put in a support ticket. I cant tell if its soho or server configuration. I know there was some issues with the exec() delimimiter soho recently set in its application and it could be as simple as that. Go the support ticket route and see if they can fix it and or have the soho gurus fix it.

Karen

Bruce Hewitt
07-15-2007, 06:02 AM
Karen

I reset the entire account.
Still battling to get my add-on domains up again - I have submitted a ticket.
I first tried to install in an add-on domain.
With the same error message.
I am installing in the main domain now.
Will submit a ticket.

Karen Mac
07-15-2007, 04:39 PM
I think its a soho issue, if you can install or upload and access the account other than that. It shouldnt matter what domain its in.. sub or main or addon..

Sorry you are having problems but support ticket is the way to go to get soho to look at it.

Karen

Bruce Hewitt
07-16-2007, 11:22 AM
Hi Karen

Submitted the ticket and got a prompt reply!
It is up and running now.

Bruce

StrictlyBusiness
03-30-2008, 01:45 AM
Ok so back to the drawing board again since I see my last topic was deleted. I don't understand why since I didn't really find a post that had issues with internal server error on soho other than through installation so I will post it here. I didn't have an installation problem. My problem is after a week of having no problems with soholaunch, all of the sudden I am unable to view my site at all and I can't log in. I still haven't received any messages back from customer support and it has been about 4 hours now. Did I post a message that was offensive or maybe there is already a post on here somewhere that I haven't came across yet and was resolved? If so then I apologize for any inconvenience. I am not trying to step on anybodys toes. Vodahost is still awesome in my book but all I am asking for is some kind of resolution to my problems. I haven't dealt with soholaunch before and I am not sure if there is any difference between bv and soho.
I did what I could in cpanel and looked at my error logs and this is what I got:
SoftException in Application.cpp:246: Directory "/home/txjhxngy/public_html" is writeable by group

I read in voda support about chmod to 755 and .htaccess and upon doing that I get this message now on cpanel:
SoftException in Application.cpp:368: Mismatch between target UID (32225) and UID (99) of file "/home/txjhxngy/public_html/index.php"

Once again my site is www.hyendelectronics.net. Thank you

Diane

Karen Mac
03-30-2008, 04:38 AM
You need to go set all your folders and files to 755, I would bet they are all 777. If you use an ftp client you can chmod whole folders at a time and all the files and subfolders under them For some reason soho is setting them all to 777 inclucding your public html. Set it to 755 manually, but there are folders you dont want readable, like htacess or cgi bin etc. then set all your soho to 755.

Karen

StrictlyBusiness
03-30-2008, 05:04 AM
You need to go set all your folders and files to 755, I would bet they are all 777. If you use an ftp client you can chmod whole folders at a time and all the files and subfolders under them For some reason soho is setting them all to 777 inclucding your public html. Set it to 755 manually, but there are folders you dont want readable, like htacess or cgi bin etc. then set all your soho to 755.

Karen

Hey Karen, thanks for your reply. I did notice that a few files were 777 and I did change the files to 755 however none of that seem to have helped. I still get the error message. As far as cgi bin and htaccess I didn't change them. So to not make them unreadable, would I change it to 644? Thanks

Karen Mac
03-30-2008, 05:23 AM
Yes.. but you have to go thru ALL of soho.. its not just a few files.. its all of them.

Karen

StrictlyBusiness
03-30-2008, 04:01 PM
Yes.. but you have to go thru ALL of soho.. its not just a few files.. its all of them.

Karen

Good Morning Karen,
The last thing I did last night before I called it quits is that I changed the cgi-bin to 644 but as far as .htaccess I could not find the file. When I did a search for it in file manager, it listed 2 files that had it. The first file pulled up all of the files in the public html and the second was the .htaccess for the poll file. Nevertheless when I got back on this morning and went to my site it is back up and running. Thank you and to cs for the help. I can get back down to business again.

Diane

StrictlyBusiness
03-30-2008, 05:58 PM
Ok nevermind. I just tried to log in and when the popup screen loads up, now from there I am getting an internal error. My site is working fine. My login screen is fine but after logging in is now the issue. Time to contact cs again.
Karen do have any suggestions? Could it be from me chmod on the files?

Diane

Karen Mac
03-30-2008, 07:07 PM
Diane.. yes.. thats why you have to go thru and chmod all soho files to 755. Internal server error is usually a misconfiguration of permissions, in this instance too loosely.

Karen

StrictlyBusiness
03-30-2008, 07:27 PM
Diane.. yes.. thats why you have to go thru and chmod all soho files to 755. Internal server error is usually a misconfiguration of permissions, in this instance too loosely.

Karen

Hi Karen,
I did just what you said. I changed all files that listed 777 and changed it to 755. I did not change the files that were already 644. I left them as is. The only file I changed was the cgi-bin which I chmod to 644. It was set on 755. I also noticed an error icon at the bottom left hand corner. I wasn't able to copy and paste but this is what it says:

Line: 2
Char: 24277
Error: Object required
Code: 0
URL://**.**.***.**:2082/frontend/x3/filemanager/index.html?
dirselect=webroot&domainselect=hyendelectronics.net&dir=%2Fhome%
2Ftxjhnxgy%2Fpublic_html

I intentionally starred out the ip address but that is what I am getting. Any idea what that means? Thanks again.

Diane

StrictlyBusiness
03-30-2008, 09:00 PM
Karen, nevermind on the reply back. I just deleted soholaunch and I am going to try oscommerce instead. I appreciate you and thanks for your help.

Karen Mac
03-30-2008, 09:42 PM
Well, You didnt have a index file that was working correctly cuz your permissions were all 777, which I tried to explain to you. If you use file manager you can only change one folder and file at a time, and it wont chmod the sub files. Thats why I suggested the ftp.

Good luck with OSCOMMERCE. SOHO is much easier to deal with and much less of a learning curve.

Karen