PDA

View Full Version : Images won't load in browser thru CSS...



Beeej21
02-08-2008, 10:54 PM
Hello all!
I am struggling with what seems to be a very simple problem. Well, the issue is extremely annoying and problematic, and I am unable to figure out the solution.

I am using CSS to load an image onto my HTML page. The reason being because I'd like to be able to swap out the images using CSS depending on the circumstance. Well, for some odd reason, the image is showing up in Dreamweaver CS3 in my desighn panel, but it does not show once I load that same page into a browser! That is very frustrating.

Here's the the link to the css file: css (http://www.soniyephotography.com/TEST/css/one.css)

Here's the link to the javaswitcher js file: js file (http://www.soniyephotography.com/TEST/css/styleswitcher.js)

Here's the link to the testing HTML page: testing page (http://www.soniyephotography.com/TEST/html/test.html)

Can someone PLEASE explain to me why Dreamweaver is showing the image in my table cell, but once I load the page into a browser ( IE, Firefox, Netscape, etc ) I do not see anything except for the background color I picked for the css tag. The background color shows up, so I know that the HTML page is connecting properly to the css file.

Please note that on the first style, that is where I'd like the image load. The other two styles don't have images ( yet ). The background color shows up perfectly, but no image. Even if I delete the background color... the image still does not show up. I am working in Dreamweaver CS3.


Please help. Thank you in advance.

Thanks again for your help and consideration.

Watdaflip
02-08-2008, 11:03 PM
I'm not sure what exactly the pages are suppose to be doing, but I the color on each of the two boxes as well as the text changes to the specified color when you click each link.

At any rate, try using an absolute link (ie. http://yoursite.com/images/image.jpg) instead the relative link (ie. ../../images/image.jpg)