PDA

View Full Version : Sitemap Problem



dean023
01-06-2006, 11:34 AM
the free sitemap isn't processing any of my pages what have i done wrong?

all my links work perfectly and I a have alot of pages that are not found - is there a manual way thats easy to do to make sure all my pages are listed/found by engines

i'd appreciate any help as i don't want the past 6 months go to waste by not being found

cheers in advance
deano

VodaHost
01-06-2006, 12:40 PM
Your links are semi perfect.

1) mouse over your links
2) look at your link in the bottom left hand corner of your screen.
3) there are symbols like #

Do you see what I mean?

dean023
01-06-2006, 01:07 PM
Your links are semi perfect.

1) mouse over your links
2) look at your link in the bottom left hand corner of your screen.
3) there are symbols like #

Do you see what I mean?

yes i've noticed that before what is causing that and how can i rectify it

( i've used the menu bar function which i presumed is what it is design for?)

VodaHost
01-06-2006, 01:25 PM
I assume you caused it ;) The fastest way to fix it is to delete the
link and do it over again.

Also make sure that you are using the latest version of BlueVoda.

http://support.vodahost.com/index.php?_m=downloads&_a=viewdownload&downloaditemid=1

dean023
01-06-2006, 05:48 PM
I assume you caused it ;) The fastest way to fix it is to delete the
link and do it over again.

Also make sure that you are using the latest version of BlueVoda.

http://support.vodahost.com/index.php?_m=downloads&_a=viewdownload&downloaditemid=1

I may have caused it but i don't know how i'm not that clever!
the links with# at the end were from the rotating banner images, i've put in a text link to the next main page and the sitemap generator has processed 3 pages but hasn't detected any pages of the navigation menu
which has many pages is this normal or should they be detected

does there need to be any other settings with the link

link type is http
url is page link i.e. http://www.electricalwholesaler.org.uk/compact.html
target is empty

thankyou for your input so far

dean023
01-07-2006, 03:08 PM
the site map generator is not picking up any pages in any navigation menus on any pages

why is this?

if i put a text link it picks these pages no problem

is it because i've copied and pasted the navigation from page to page?

I also had to reduce the number of sub pages on the navigation menu before it would publish which makes me think there might be some other problem with my program - is there a limit to how many sub sections you can have?

you help would be appreciated as there is something not right and i've done nothing wrong as far as i can see

my version is 7.6 is this the latest version? i used the link you provided and downloaded which should automatically update is that right?

cheers
deano

dean023
01-07-2006, 03:24 PM
the site map generator is not picking up any pages in any navigation menus on any pages

why is this?

if i put a text link it picks these pages no problem

is it because i've copied and pasted the navigation from page to page?

I also had to reduce the number of sub pages on the navigation menu before it would publish which makes me think there might be some other problem with my program - is there a limit to how many sub sections you can have?

you help would be appreciated as there is something not right and i've done nothing wrong as far as i can see

my version is 7.6 is this the latest version? i used the link you provided and downloaded which should automatically update is that right?

cheers
deano

it doesn't pick up from go menu's either - really need to sort this problem
your assistance would be highly appreciated.

VodaHost
01-09-2006, 06:52 PM
Ok...the one of the problems is your shopping cart. It is generating
ASP pages..

http://www.romancart.com/cart.asp?storeid=16795&itemname=GET_GA155GK&price=2.25&quantity=1

These are active server pages. This means that they are generated on the
fly...you can not sitemap asp pages because they do not exist until they
are created by the user.

ASP pages could ce causing ROR to fail..but I am not sure, What I do now is
that search engines do not index asp pages.

dean023
01-10-2006, 01:03 PM
Ok...the one of the problems is your shopping cart. It is generating
ASP pages..

http://www.romancart.com/cart.asp?storeid=16795&itemname=GET_GA155GK&price=2.25&quantity=1

These are active server pages. This means that they are generated on the
fly...you can not sitemap asp pages because they do not exist until they
are created by the user.

ASP pages could ce causing ROR to fail..but I am not sure, What I do now is
that search engines do not index asp pages.


ok thanks for that ... so is there a manual way of creating a site map and list all my pages as oppose to the automatic way using the generator?

many thanks

dean023
01-10-2006, 05:18 PM
I for got to mention also that the shopping cart links don't appear until after the index page/pages that contain the navigation menu.
and therefore should be detected

could you answer the previous question about the limit of links within the navigation menu as i think this has something to do with it. ( I had to reduce the amount of links to enable the navigation menu to publish - all the page published except the navigation menu) and this is what is not being detected

VodaHost
01-10-2006, 05:31 PM
yes, you can manually create a page called sitemap.html and add
a hyperlinks to all your pages. Also add a brief description of every
page.

dean023
01-11-2006, 08:06 PM
yes, you can manually create a page called sitemap.html and add
a hyperlinks to all your pages. Also add a brief description of every
page.

is there anything i need to do with the description so its pcked up or just type it below each link?

thanks for your help....you still haven't answered about the limit of links in the navigation menu posted earlier

Deano

VodaHost
01-11-2006, 09:59 PM
1) No.
2) No limit.

dean023
01-13-2006, 01:21 PM
1) No.
2) No limit.

2) it that case there is a problem. I had to reduce the amount of links before it would publish - everything appeared on the page except the navigation menu, when i reduced it published fine.

I think this is also the problem why the sitemap is not picking up any links as none of these are asp pages, and the # appearing on the image banners

something sounds as though its not quite right. what do you think?

VodaHost
01-13-2006, 02:23 PM
I think it is a combination of # and asp pages.

dean023
01-13-2006, 03:17 PM
i'll just do a sitemap page. thanks for your help

VodaHost
01-13-2006, 04:42 PM
my pleasure.