PDA

View Full Version : A simple problem with a sound file



AussieVodaGirl
02-03-2006, 01:40 AM
I've uploaded an mp3 file to my public file on the server but am having problems inserting it onto the page. I have a graphic that I want people to be able to click on to hear.

I've tried going into object properties and putting the link to the sound file into the graphic, but as my domain is an add-on, do I need the file to read www.mymaindomain.com/add-ondomain/soundfilename.mp3 (http://www.mymaindomain.com/add-ondomain/soundfilename.mp3) ? I've tried with and without the main domain name but neither works.

Alternatively I've tried clicking on the media icon on the left of the page which also asks me for the file name. What should I be entering for 'link type'. The drop down menu only has http,gopher,mailto etc. Is sound still an http file type?

Any help appreciated!

navaldesign
02-03-2006, 06:50 AM
I've uploaded an mp3 file to my public file on the server but am having problems inserting it onto the page. I have a graphic that I want people to be able to click on to hear.

I've tried going into object properties and putting the link to the sound file into the graphic, but as my domain is an add-on, do I need the file to read www.mymaindomain.com/add-ondomain/soundfilename.mp3 (http://www.mymaindomain.com/add-ondomain/soundfilename.mp3) ? I've tried with and without the main domain name but neither works.

Alternatively I've tried clicking on the media icon on the left of the page which also asks me for the file name. What should I be entering for 'link type'. The drop down menu only has http,gopher,mailto etc. Is sound still an http file type?

Any help appreciated!

The link has nothing to do with main or subdomain. It has to do with actual location of the file. Most probably is the name of the file that creates the problem because usualy mp3 file names are something like : "shakira - suerte.mp3" when it should be "shakira_suerte.mp3" Browsers don't accept file names with spaces, they need Underscores. When there is a space they will see the file as "shakire" without the rest, resulting in a Page not Found Error. Try http://www.navaldesign.info/Deamonox/shakira_suerte.mp3

AussieVodaGirl
02-03-2006, 07:33 AM
Thanks for that. I actually solved the problem myself (after about 3 hours of trying mind you!). After adding the file to the public server I just clicked on the graphic and put the URL as the simple file name - not the full URL as I was led to believe from the videos. i.e. I didn't need any www. xxx/xxx before it. Don't know why, but it's working so that's all I'm worried about! Thanks again for taking the time to respond.

navaldesign
02-03-2006, 11:02 AM
Thanks for that. I actually solved the problem myself (after about 3 hours of trying mind you!). After adding the file to the public server I just clicked on the graphic and put the URL as the simple file name - not the full URL as I was led to believe from the videos. i.e. I didn't need any www. xxx/xxx before it. Don't know why, but it's working so that's all I'm worried about! Thanks again for taking the time to respond.

This is because your link lies in page that is already on the server, in the same folder with the file. If you want to link to a file that's on another folder, you must put /folder/filename.mp3 . If the file is on another server, you must have the whole http:/...........