PDA

View Full Version : IFrame not positioning correctly - I think!



cooljac
08-13-2006, 07:24 AM
I created my first two or three pages for my site, www.christian-lyric-warehouse.com (http://www.christian-lyric-warehouse.com). I followed Naveldesign's instructions. Thank you very much for posting that. It helped a lot! My problem (or lack of knowledge) is, I made the iframe the exact size I need to hold the menu and placed it in the exact spot where I want the menu. But, what happened is, it was cropping out part of the menu when the page loaded. You won't see that now. I have had to place the iframe at the very top left of the page. Then the menu shows up correctly. But, it shouldn't. It should be cut off. I don't understand why this is happening. As a result, I cant use that portion of the page for anything else. Naveldesign, if you are reading this, can you give me a pointer or two?

Note: right click below the blue area to get the page code.

navaldesign
08-13-2006, 10:07 AM
I frames will display the page that they are linked to, starting ALWAYS from the very top left corner. So, if your frame is excactly the same size as your menu, the menu itself has to be placed at the very top left corner of it's own page, otherwise it will be "cropped"

As a good advise, however, make the I frame a bit BIGGER than the menu itself, so if in the future you need to add some more buttons, or widen the bar a little, you won't need to change the i frame in all your pages.

cooljac
08-14-2006, 07:13 AM
Good advice. Thanks. This is going to be a fun learning experience!