PDA

View Full Version : 40 blank emails a day



Montana
02-15-2006, 09:23 AM
I received each and every day around 40 emails.
Blank.
Propreties shows...


Return-path: <nobody@voda3.vodahost.com>
Envelope-to: newsletter@vozencheres.com
Delivery-date: Wed, 15 Feb 2006 01:16:57 -0600
Received: from nobody by voda3.vodahost.com with local (Exim 4.52)
id 1F9GuH-0003AK-3W
for newsletter@vozencheres.com; Wed, 15 Feb 2006 01:16:57 -0600
To: newsletter@vozencheres.com
Subject: Newsletter-inscription
From:
Message-Id: <E1F9GuH-0003AK-3W@voda3.vodahost.com>
Date: Wed, 15 Feb 2006 01:16:57 -0600
X-Antivirus: AVG for E-mail 7.1.375 [267.15.7/259]
Mime-Version: 1.0
Content-Type: text/plain

Values submitted from web site form:


--
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.375 / Virus Database: 267.15.7/259 - Release Date: 13/02/2006


I asked butl no answer yet..must be busy busy...
Ticket ID: AXE-109428

How can I solve this problem?

Montana
02-15-2006, 09:50 AM
I wonder...
I re-read the tutorial about forms and ...the php script has to be uploaded in public.html
I uploaded it in public.html/vozencheres cause the form is part of a new site. Did I make a mistake or is it OK?
I try to figure out where is the problem...

VodaHost
02-15-2006, 09:54 AM
You have probably configed your script wrong...You must load it into your public_html.

navaldesign
02-15-2006, 11:23 AM
I wonder...
I re-read the tutorial about forms and ...the php script has to be uploaded in public.html
I uploaded it in public.html/vozencheres cause the form is part of a new site. Did I make a mistake or is it OK?
I try to figure out where is the problem...

If your form is in the subfolder and the script is the one provided in the tutorials, as it is given, then the script gets uploaded in the same folder as the form. Otherwise you must specify in the script the path to the php file.

Montana
02-15-2006, 01:45 PM
Ok I tested the two options...
in Public_hml....Doesn't work
in public_htlm/vozencheres ...just perfect...
so the problem with the blank emails is not linked to the upload of the php script.

The form works well.
I collect the informations with outlook express with the good email address...
Auto responder works well too.

But in CPanel I didn't receive any message (my testings)...

Does someone had the same kind of problem before?

Thank you for your help early birds...

Montana
02-15-2006, 03:12 PM
And...another bunch of blank emails..

what to try and what to do...???

navaldesign
02-15-2006, 04:02 PM
And...another bunch of blank emails..

what to try and what to do...???

Please upload the script code so we can have a look.

navaldesign
02-15-2006, 05:50 PM
Ok I tested the two options...
in Public_hml....Doesn't work
in public_htlm/vozencheres ...just perfect...
so the problem with the blank emails is not linked to the upload of the php script.

The form works well.
I collect the informations with outlook express with the good email address...
Auto responder works well too.

But in CPanel I didn't receive any message (my testings)...

Does someone had the same kind of problem before?


Thank you for your help early birds...

You don't get any emails in CP because when you download your messages with Outlook Express the messages get deleted from your inbox. You might have a problem with the script looping and causing the server messages. If you upload the script i'll have a look

Montana
02-15-2006, 07:24 PM
Here is the script...
<HTML>
<HEAD>
<TITLE>Merci de vous &#234;tre abonn&#233; &#224; notre newsletter</TITLE>
</HEAD>
<BODY>
<H2>Merci d'avoir rejoint la communaut&#233; des lecteurs de la newsletter de vozencheres.com!
<FONT style="FONT-SIZE:14pt" color="#000000" face="Arial"><B>IMPRIMEZ VOS AFFICHETTES CLIQUEZ<A href="<A href="http://www.vozencheres.com/voiture_imprimable.html">ICI</FONT><FONT">http://www.vozencheres.com/voiture_imprimable.html">ICI</FONT><FONT style="FONT-SIZE:9pt" color="#000000" face="Arial"></B></A>&nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp; &nbsp;&nbsp;&nbsp;&nbsp; </FONT>
<FONT style="FONT-SIZE:14pt" color="#000000" face="Arial"><B>RETOUR CLIQUEZ<A href="<A href="http://www.vozencheres.com/index.html">ACCUEIL">http://www.vozencheres.com/index.html">ACCUEIL GUIDE</A></B></FONT></H2>

<?PHP
$email = $HTTP_POST_VARS[email];
$mailto = "newsletter@vozencheres.com";
$mailsubj = "Newsletter-inscription";
$mailhead = "From: $email\n";
reset ($HTTP_POST_VARS);
$mailbody = "Values submitted from web site form:\n";
while (list ($key, $val) = each ($HTTP_POST_VARS))
{
$mailbody .= "$key : $val\n";
}
mail($mailto, $mailsubj, $mailbody, $mailhead);
?>
</BODY>
</HTML>

Thank you very much for your time and help.

navaldesign
02-15-2006, 09:45 PM
Well, the script is ok. Is there a chance that someone is playing with your form?

Montana
02-16-2006, 08:36 PM
As far as I know...no.
Thank You for your help.