PDA

View Full Version : PHP available options?



tarla_a
02-24-2006, 10:30 AM
Have some questions regarding available php options:

1. Support for large file upload(5-10M jpgs)?
2. Support for .htaccess files?
3. GD version?
4. Exif functions?
5. ImageMagik?
4. MySQL version?

Thank you.

Nica423
06-26-2008, 04:17 AM
How do I disable the mod security. It is cause my gallery and my profile comment mods to redirect to a 406 error when I try to edit them. I read that disabling mod security would help. I have a code for that but don't know how to access the .htaccess file.

Don't know which is the correct thread to post for help in.
mom-me-dearest.com

navaldesign
06-26-2008, 09:38 AM
VH server settings allow for local .htaccess files. So simply create it in Notepad, and upload it in the folder where it is required.

Nica423
06-26-2008, 04:21 PM
Thank you for your response. But i don't understand what folder it is required in. Where are these files on server settings?

Very much in the dark.

navaldesign
06-26-2008, 04:49 PM
You should add (or modify, if it exists) the htaccess file in your gallery folder.

Nica423
06-26-2008, 05:07 PM
Thank you. That's a little clearer for me.
I am a pretty quick learner, but I am definitely still learning my way around.
I still would appreciate some direction on contacting the Admin to tone down the mod security. I have been reading the threads extensively and learned that, this is most likely what is causing this error message when I try to edit the gallery or profile comments:

Not Acceptable

An appropriate representation of the requested resource /MomMe/index.php could not be found on this server.
Apache/2.2.8 (Unix) mod_ssl/2.2.8 OpenSSL/0.9.8b mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at mom-me-dearest.com Port 80

But I have yet to read any solution yet.

navaldesign
07-01-2008, 09:58 AM
That's a 301 redirect from your "form.html" to another site's "form.html" page through your index.php page

Did you put it there ?

curtley@iburst.co.za
07-02-2008, 07:21 PM
Hi Naval!

I Saved and republished my index page as "index.php" - My page properties is .html.
I still find the same problem when logging on: www.buildnat.com (http://www.buildnat.com)
Problem is: A file I have to download or save.
How can I solve my problem?

Thanks!

Ambrose

Nica423
07-02-2008, 08:42 PM
That's a 301 redirect from your "form.html" to another site's "form.html" page through your index.php page

Did you put it there ?

Greetings Navaldesign,

I am not sure if the question posed in the above reply was directed to me or not.

But if so, I placed no redirect in the index.php page.

I am having great difficulty with getting this error resolved. I have placed several support tickets to no positive end as yet.

I have requested that mod security be toned down or disabled and have been passed back and forth between SMF & VoddaHost, again to no positive end.

I have two sites on Voda and my experience here has been generally good. I keeping reading threads and other web articles and posting queries and hoping someone can help me.

Can you?
www.mom-me-dearest.com

navaldesign
07-02-2008, 09:02 PM
The reply was for curtley.

From what i read, you need to create a htaccess file in your SMF directory (or add the code to the existing one, if any) with the following code:


<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
SecFilterCheckURLEncoding Off
</IfModule>


However, it is not something i have done, so i don't know if it works or not.

Nica423
07-02-2008, 09:17 PM
The reply was for curtley.

From what i read, you need to create a htaccess file in your SMF directory (or add the code to the existing one, if any) with the following code:


<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off
SecFilterCheckURLEncoding Off
</IfModule>


However, it is not something I have done, so I don't know if it works or not.

I will try that code again, perhaps I have not tried it in the correct directory. I placed it in the public_html/MomMe. It causes a 500 Error there.

There is an existing .htaccess file there. Gonna try creating different folder and placing in SMF folder.

Hope to find solution. Seems to be many people in the threads experiencing same.

Thanks fo quick reply.