PDA

View Full Version : email links don't work



lalletti
08-17-2009, 07:14 PM
hello,
this is laura mura and my url is www.producilmiodisco.org.
the email button I included in my navigation bar, using the mailto: feature in the links window, just doesn't work: when I open a page from any browser and I click on the word "email", nothing happens. all the other links they do work,
I don't know what's wrong with that. it's the same thing in every page of the site and I did not find any specific tutorial on this...

DarrenC
08-17-2009, 07:19 PM
I cant test it because you havent published an 'index' page yet.

lalletti
08-17-2009, 07:25 PM
oh, yes, you can, please go to http://208.43.222.138/~ewdblkxh/test.html

DarrenC
08-17-2009, 07:32 PM
Email link does work but remember this will only work if the visitor has an email program, such as Outlook or Outlook Express

I personally find links like that irritating. I would direct your visitor to a contact page with a contact form on it. and then a mailto: link on this page so the visitor can chose to use it or not.

lalletti
08-17-2009, 07:44 PM
ok, I did that because I am irritated when I run into forms, because I feel like I'm being kept at a distance, while I wanted to be friendly :)
thaks anyway

DarrenC
08-17-2009, 07:50 PM
Fair enough but you should be thinking of your visitor and not thinking about you....smiling!!

Good luck with your site..its looking good

lalletti
08-18-2009, 08:36 AM
yes, you are right, only I didn't get what you said: it can be annoying not because your email software pops up, as I thought at first, but because those who don't have one can't send any email if I choose that option! sorry, I am not so comfortable with the english language, so I misunderstood.
ok, now I did what you said: I tried with a form, but I tested it and doesn't work!!! why??? url:http://208.43.222.138/~ewdblkxh/test.html