PDA

View Full Version : Help adding subpages



newadmin
01-08-2010, 01:28 AM
I'm trying to add subpages to my site but it doesn't seem to be working!

my site is animeramune.com and everytime i try to add the "Staff", "Contact us"..etc subpages it doesn't seem to work.

I've been through all the video turorials and they don't seem to tell me how to add subpages to my site.

i've tried everything but i keep getting
"The requested URL /subtest was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Error"

can anyone help?!

millie
01-08-2010, 08:05 AM
Hi

Perhaps you are confused as to the word 'subpages'. They are just other pages that is linked to your index page. For example, create a page called "staff" (which of course will in turn be called staff.html when you publish {note the lower case letters}). From your index page, the link to this will be http://www.animeramune.com/staff.html. From a browser, the URL will be the same. That means you can get to the 'subpage' without passing by the main page.

Perhaps you missed this part from the videos

Good luck

DarrenC
01-08-2010, 10:14 AM
Have you published each page individually?

millie
01-08-2010, 12:37 PM
Silly me. Darren is absoloutely correct. I forgot to mention that all the pages must be published. Otherwise, there will not be an address. Which means you cannot link to them.

Cheers

newadmin
01-08-2010, 07:55 PM
Have you published each page individually?


I create a page then I save it with "Save page as", after which I click on "Publish".

I publish the page to the public/html folder on my site server but it doesn't work.

For example, I created a page and labeled it "subpagetest" and then published it to the public/html folder.
Then I went to my index page and edited my subpagetest tab to direct to "animeramune.com/subpagetest" though when republish the index page, the subpage doesn't appear. Only an error message.

millie
01-09-2010, 03:11 AM
Perhaps it should be animeramune.com/subpagetest.html? did you forget the '.html' extension?

Cheers