PDA

View Full Version : Pages not publishing - error Code 404



Seyonne
01-19-2010, 05:23 AM
Hi everybody!

This is what I have done so far to solve the publishing issues I have with my home page, estimates page, and contact us page.

-made sure my pages are saved properly with no caps, no spaces, use of underscore with NO file extension.
-made sure my home page is named index.
-made sure my saved page files show as .bvp
-entered in the page links as http://www.stonewallcleaner.ca/index.html
-my files are all public files

I am pretty sure that the problems have to do with the forms.
-I used the form creator.
-I did not include any spaces in the form name.
-I created a success and error page and left the links at default? Not sure if that is correct.

AND I did actually publish them all. Lots of gobbly gook in the under layer of my webpage. Does that mean each form must have it's own page to work. My home page has an email sign-up form embeddded in it.

Any help appreciated. Please test the home page one for forms. I have not had a chance to get the other ones set up yet. They are not complete.

Thanks,
Complete Newbie!

Collectors-info
01-19-2010, 06:10 AM
Need to make your index page & contact page with .php extensions via the page properties & then save & republish.
NOTE: Completely delete your existing index page 1st that has a html extension from your servers control panel as the SE will look for this html page 1st.
You will also have to do all the links back to these pages again on your other pages.
The index page also only has the be linked to as http://www.stonewallcleaner.ca (http://www.stonewallcleaner.ca/index.html) without the index part.

Seyonne
01-19-2010, 06:22 PM
Hi Chris,
I am still having problems unfortunately.

I first deleted my existing html index page from the server files.
Then I changed the page properties for the contact and index page to php. I checked to make sure all pages with forms had this page extension.
I corrected the link for home page on all pages to http://www.stonewallcleaner.ca only
I finished linking the success and error pages for the other pages using http://www.stonewallcleaner.ca/success.html etc.
I can bring up the home, about us, services, and FAQ pages. I bring up the estimate and contact us page but with code in the background. I can't link back anywhere to the home page still. sighhhhhh.

I know I am doing something wrong but I am running out of time to fix this. Gotta get back to business. Any help appreciated!

Marincky
01-19-2010, 06:28 PM
Your home page link in your top navigation works fine on every page. At the bottom of your pages the link to the home page doesn't because you put index.html instead of index.php in the link

Re do these links and leave off index altogether, Just your domain name will take you to your home page

Collectors-info
01-19-2010, 06:38 PM
Ditto with Ramsey. You need to go through every page & check every link.

Seyonne
01-19-2010, 09:11 PM
THANK YOU!!! I love this program. Thanks for your help Ramsey and Chris.