PDA

View Full Version : HTML box location on page



Knildon
11-11-2015, 06:32 AM
Hello,
I have an unpublished page that I am working on and I am trying to add a "Buy Now" button from PayPal to the page. When I place the button's HTML box where I would like to have it and then look at the preview, the button is no where close to where I want it to be. How do I get it to stay where I put it?
I have watched all the appropriate tutorials and did as instructed. One tutorial said to just place the box where I wanted it to be. No luck!!! Box keeps moving to where it wants to be.
I have another HTML box on the same page and it stays where I place it.
I have read through as many other threads as my eyes allow and found nothing that actually answers my question.
Not being an expert on this I rely on the advice given in this forum and if available on the internet. I thought it might have something to do with the settings in the drop down box in the properties section but I couldn't find anything that explains how to use them. One of your moderators said it was too much to explain and just Google it to get an answer to that question.
I've seen a number of questions relating to my question and unless I'm just to dumb to understand the answers (possible) I haven't seen a good answer.
I would greatly appreciate an answer, in layman's terms, to this question and possibly, in the near future, add something to the user's manual and tutorials to cover the items listed in the properties drop down menu.
Thanks in advance for any advice given.
Don

VodaHost
11-11-2015, 08:44 AM
Hi, the usual cause of objects moving around on the page are images that have not been resized, this can cause the box to be forced out of place. We would recommend you resize all your images, then insert them into the page again, then insert the HTML box.

Knildon
11-12-2015, 01:44 AM
Thanks for the quick response. Unfortunately I do not have any images on the page. The page consists of an HTML box with code for the customer to enter his info into, some text on the page explaining the item for sale and the PayPal button. I have tried deleting every thing and starting over but the same result no matter where on the page I put that box it doesn't stay.
As I referred to in my original thread, does the <div>, no <div>, home, etc., etc. have anything to do with this problem?
Since my programming efficiency is not in building web pages, when I do something as instructed and it doesn't work I am lost as to how to fix it.
Don

Knildon
11-12-2015, 03:05 AM
I believe I found the problem!!!
I published the page and then looked at the HTML code generated at the server. The page had a very large box around the HTML code from my other HTML box.
I went back to my design page and found that the table around the HTML code wasn't closed.
ie;
<table>
"HTML code"
<table> <----- Should have been </table>
It appears all is OK now. I hope??
As they say, even a blind squirrel finds a nut once in a while.
Thanks for the help and idea.
Don