What went wrong with the update?

I expect you have clashing file names and folders. Try and install 3.x.x in a new folder or delete any files/folder which may be clashing.