Results 1 to 5 of 5

Thread: Flash Element Slide Show
      
   

  1. #1
    Join Date
    Apr 2008
    Posts
    1

    Question Flash Element Slide Show

    Domain: anchorrealtyltdtc.com

    CLIENT ID #23777



    We have requested for more than 3 weeks assistance with our flash slide show not displaying on the index page of our website www.anchorrealtyltdtc.com

    The support help desk constantly keeps telling me that it is a design issue.

    My last question sent to them entails the following: How is it that when this link (below) is copied into the web broswer the flash silde show is working, but the link does not work in the embedded flash element when accessed through the website???

    http://www.anchorrealtyltdtc.com/Show1/SlideShow.swf

    Thanks.

    Terrance Adams

  2. #2
    Join Date
    Feb 2006
    Location
    Kings Lynn Norfolk UK
    Posts
    8,702

    Default Re: Flash Element Slide Show

    Hi, there must be some incomparability with the program your using. But! if you pop that url into an iframe, it works fine.

    Good luck.

  3. #3
    Join Date
    Mar 2006
    Posts
    14,683

    Arrow Re: Flash Element Slide Show

    Quote Originally Posted by tadams View Post
    The support help desk constantly keeps telling me that it is a design issue.
    My last question sent to them entails the following: How is it that when this link (below) is copied into the web broswer the flash silde show is working, but the link does not work in the embedded flash element when accessed through the website???
    http://www.anchorrealtyltdtc.com/Show1/SlideShow.swf
    This link is improperly written, as it demands the browser to look for a non-existant directory "Show1".......

    The link needs to be written for a specific file that has been uploaded to your public_html directory/ individually: if the single .swf file is called "show1" then you link that is specified in the Flash box in BV would look like www.anchorrealtyltdtc.com/show1.swf and if you have simply named it "slideshow" (something I would consider renaming, to keep them identifiable), it would look like www.anchorrealtyltdtc.com/slideshow.swf


    Each Flash file needs to be individually uploaded to your main directory to be recalled, and that must be the same directory as the page to which is calling it to present (the public_html/ directory, not "Show1").

  4. #4
    Join Date
    Apr 2008
    Location
    The Dark Side
    Posts
    559

    Default Re: Flash Element Slide Show

    Depending on the way the slideshow was made depends on how it can brought to a page.
    To start with this code is wrong.
    Code:
     
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="465" height="289" id="Flash1">
    <param name="movie" value="http://www.anchorrealtyltdtc.com/Show1/SlideShow.swf">
    <param name="quality" value="High">
    <param name="scale" value="ExactFit">
    <param name="wmode" value="Window">
    <param name="play" value="true">
    <param name="loop" value="true">
    <param name="menu" value="false">
    <param name="sAlign" value="L">
    <embed src="http://www.anchorrealtyltdtc.com/Show1/SlideShow.swf" width="465" height="289" quality="High" wmode="Window" loop="true" play="true" menu="false" scale="ExactFit" type="application/x-shockwave-flash" pluginspace="http://www.macromedia.com/go/getflashplayer">
    </embed>
    </object>
    should be

    Code:
     
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=5,0,0,0" width="465" height="289" id="Flash1">
    <param name="movie" value="/Show1/SlideShow.swf">
    <param name="quality" value="High">
    <param name="scale" value="ExactFit">
    <param name="wmode" value="Window">
    <param name="play" value="true">
    <param name="loop" value="true">
    <param name="menu" value="false">
    <param name="sAlign" value="L">
    <embed src="/Show1/SlideShow.swf" width="465" height="289" quality="High" wmode="Window" loop="true" play="true" menu="false" scale="ExactFit" type="application/x-shockwave-flash" pluginspace="http://www.macromedia.com/go/getflashplayer">
    </embed>
    </object>

    the problem starts if the flash program used to make the slideshow uses a xml file and a images folder. When this is the case the swf will look for the xml file in the same directory. And when it can't find it one of two things will happen 1/ you get a blank screen, 2/ you just get the player controls .
    In programs were all the information is stored on the swf file the above code should solve the problem.


    To solve the problem if you have a xml file and folders you have two options.
    1/ move the xml and the folders into the same directory of the page published
    2/ by putting a ifame of the exact size of the movie on your page. Then make a new page put a html box on the page enter the code above but remove the /Show1/ from this
    <param name="movie" value="/Show1/SlideShow.swf">
    and this part
    <embed src="/Show1/SlideShow.swf"
    make the box the exact size of you movie, place this in the top left of the page.then in page properties, make the page the same size as your movie and check the center in page. Now save and publish to the same place as your xml swf and folder are in this case the /Show1 folder. Then no your with the iframe open the iframe and in the url enter the full url of the page you published in the Show1 . Close save and publish to the same place you puplished it before.

    You can see two of this sort of iframe on this site notice the two menus. Here

  5. #5
    Join Date
    Apr 2008
    Location
    The Dark Side
    Posts
    559

    Default Re: Flash Element Slide Show

    just a little tip if your using the iframe option then the address in the iframe should be http://www.anchorrealtyltdtc.com/Show1/thepageyoumade.html

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •