Results 1 to 3 of 3

Thread: HTML link not working?
      
   

  1. #1
    Join Date
    Dec 2006
    Posts
    181

    Default HTML link not working?

    Hey all, I am trying to set up the ClickBank link to the 'buy' page on my website, which site is still under construction. ClickBank says this:

    You’ll need to manually create the payment link to send customers to the order form, and then insert this payment link in HTML code on your Pitch Page. Put the HTML code for your payment link in the following format:
    http://ITEM.VENDOR.pay.clickbank.net


    <a href="http://ITEM.VENDOR.pay.clickbank.net" target="cb">CLICK HERE TO PURCHASE</a>

    I have inserted/changed the Item and Vendor (me) and tried to create an HTML box on my Order page, but the link doesn't work. Instead of reading the above http:// (+ my inserted stuff) it has added on my URL as a prefix. I don't know how to change that, coz I just inserted the above ClickBank's "Click Here to Purchase" HTML code into BV's HTML properties box.

    In other words, instead of reading http://ITEM.VENDOR.pay.clickbank.net (or my version thereof) it's reading {my URL}http://ITEM.VENDOR.pay.clickbank.net - resulting in a broken link.

    Any ideas? Thanks in advance,

    Will
    A manual to help small-business owners . http://www.entrepreneurshipz.com

  2. #2
    Join Date
    Mar 2006
    Posts
    14,683

    Arrow Re: HTML link not working?

    The first Rule in affiliate marketing is to not mess with (edit) with the hyperlinks provided, and the second Rule is to use them they way you are obliged. Especially when you don't really know what you're doing yet as a new "Publisher."

    You need to do some homework on Affiliate Marketing and Affiliate Links, and you can start by diving into this post.

    For a more thorough education, I'd suggest you do a Forum Search on "affiliate links" + my name ("Vasili") to pull up posts (not threads) containing many discussions that will save you time and frustration.
    . VodaWebs....Luxury Group
    * Success Is Potential Realized *

  3. #3
    Join Date
    Dec 2006
    Posts
    181

    Default Re: HTML link not working?

    Hey Vasili, thanks for the info.

    Ah! Solved. Went to one of the threads you said, and when you specifically talked about *text* links, the light went on. I had been trying to use the HTML box, which I guess is for use with IMAGES, but if I was using a simple text link (to keep it simple) then I don't need to do that. So I created a simple text phrase ("CLICK HERE TO PURCHASE") and hyperlinked *that* to the above http://ITEM.VENDOR.pay.clickbank.net (with my additions added) and it worked.

    Messing with the hyperlinks? Dunno, surely I was doing what CB says to do? Which is to replace the 'ITEM' with the number of products you have with them (in my case, 1) and the Vendor name with my CB name, which is what I did. CB says this:

    You must customize this HTML code to link to the order form for your specific product:

    • Replace ITEM with the item number of the product for sale. As you set up products to sell in your ClickBank account, each product will be assigned a unique number: 1, 2, 3, etc. If you are setting up your first product, the item number is 1.
    • Replace VENDOR with your ClickBank account nickname.
    Anyway, I tested it in both preview and published mode, and it's taking me to the CB Buy page. Yippee! LOL. One more problem solved.

    Tks, Will
    A manual to help small-business owners . http://www.entrepreneurshipz.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •