Announcement

Collapse
No announcement yet.

cPanel email problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • cPanel email problem

    Hi,
    I have a problem. If anyone has had this problem & has solved it, please advise solution.
    I have designed my website. When I added my email, I have done exactly what it has said to do in "creating an email with email form tutorial" and have even uploaded a php file. Everything works except for the senders email address. When I go into cPanel, in the senders details N/A appears. I have gone over everything to do with email form again & again and have even started from the begining and it still comes up N/A in senders details. I have sent an email to my cPanel email address from by Outlook address and the email arrives with my email address, so it has something to do with Bluevoda. Does anyone have any solutions? Or do I have to have a professional take a look.
    Thanks Lisa

  • #2
    Hi Lisa,

    I am Sorry, I really donít understand your questions.
    Please be kind enough to rephrase and reformat to a
    clear and understandable...

    1)First Question Goes Here.
    2)Second Question Goes Here.
    3)Etc....

    Also Please do not post that same question in 3 diffrent forums


    George
    Last edited by VodaHost; 07-09-2005, 06:22 PM.
    George Fountakos
    VodaHost
    www.VodaHost.com
    Your Website People
    +1-302-283-3777 USA / Canada / International
    (0044) 020 8816 8319 / United Kingdom

    Comment


    • #3
      Dear George,

      I have a email problem in cPanel.
      My website is nearly complete, although;
      1) When I test the newsletter request on my website I enter a name & email address and click GO, I have a problem when I check my email inbox in cPanel.
      2) In my inbox, the sender comes up as N/A.
      3) I have done exactly what it has said to do in "creating an email with email form tutorial"
      4) I have even uploaded a php file.
      5) Everything works except for the senders email address doesnot appear. When I go into cPanel, in the senders details N/A appears.
      6) I have gone over everything to do with email form again & again and have even started from the begining and it still comes up N/A in senders details.
      7) I have received emails from people & companies in my cPanel email and their names appear. Its only when an request is sent from my website that N/A appears.
      Does you have any solutions? Or do I have to have a professional take a look.
      Thanks Lisa

      Comment


      • #4
        Ok,,It sounds like you did something wrong. I can not diagnose what you
        did wrong because the page resides on your local computer in your home/office.
        If you are only having a problem with email field. Try deleting it and redoing it.
        Having a pro.. take a look at it never hurt.

        VodaHost

        Your Website People!
        1-302-283-3777 North America / International
        02036089024 / United Kingdom
        291916438 / Australia

        ------------------------

        Top 3 Best Sellers

        Web Hosting - Unlimited disk space & bandwidth.

        Reseller Hosting - Start your own web hosting business.

        Search Engine & Directory Submission - 300 directories + (Google,Yahoo,Bing)


        Comment


        • #5
          Hi *****,
          I know where I am making the mistake, it is in form properties.
          1) I have named my form name: newsletter
          2) I have put in Action: newsletter.php
          3) Method: POST
          4) Encoding type: left blank
          5) uploaded a php file named newsletter.php
          When I save & publish and test my newsletter request, it goes to a page "index of/newsletter.php"
          Can you please advise what I am doing wrong.
          Thanks Lisa

          Comment


          • #6
            What does "index of/newsletter.php" mean?
            George Fountakos
            VodaHost
            www.VodaHost.com
            Your Website People
            +1-302-283-3777 USA / Canada / International
            (0044) 020 8816 8319 / United Kingdom

            Comment


            • #7
              Dear George,

              I do not understand what it means either. Thats why I am asking you. My website is www.productshop.com.au please go to it and request an email and see what happens.
              Thanks Lisa

              Comment


              • #8
                Okay, I think I have found out your problem. Your form is on your index page, so your php file needs to be saved as index.php not newsletter.php. Do this and upload the new php file and everything will work.

                George
                George Fountakos
                VodaHost
                www.VodaHost.com
                Your Website People
                +1-302-283-3777 USA / Canada / International
                (0044) 020 8816 8319 / United Kingdom

                Comment


                • #9
                  I am still getting N/A in my cPanel's - email senders details. Please check to see if I have done everything corrrectly in my form properties.
                  1) I have named my form name: index
                  2) I have put in Action: index.php
                  3) Method: POST
                  4) Encoding type: left blank
                  5) uploaded a php file named index.php
                  Thanks Lisa

                  Comment


                  • #10
                    Hi Lisa,

                    There must be a mistake in the index.php file.
                    How does the contents look like?

                    For detailed instructions about forms read this:
                    http://www.vodahost.com/vodatalk/showthread.php?t=933

                    Pablo
                    Forum Moderator
                    BlueVoda Spe******t

                    Comment


                    • #11
                      Hi Pablo,

                      Please see my index.php file I have uploaded. Please advise any changes that are required.

                      <HTML>
                      <HEAD>
                      <TITLE>Succesfully processed your request</TITLE>
                      </HEAD>
                      <BODY>
                      <H2>Thankyou for your request!</H2>
                      <?PHP
                      $email = $HTTP_POST_VARS[email];
                      $mailto = "info@productshop.com.au";
                      $mailsubj = "ProductShop Newsletter";
                      $mailhead = "From: $email\n";
                      reset ($HTTP_POST_VARS);
                      $mailbody = "Values submitted from web site form:\n";
                      while (list ($key, $val) = each ($HTTP_POST_VARS))
                      {
                      $mailbody .= "$key : $val\n";
                      }
                      mail($mailto, $mailsubj, $mailbody, $mailhead);
                      ?>
                      </BODY>
                      </HEAD>

                      Comment


                      • #12
                        Hi Lisa,

                        Try making your code like this, and then uploading again:

                        <HTML>
                        <HEAD>
                        <TITLE>Succesfully processed your order</TITLE>
                        </HEAD>
                        <BODY>
                        <H2>Thanks for your order!</H2>
                        <?PHP
                        $email = $HTTP_POST_VARS[email];
                        $mailto = "put your email address here";
                        $mailsubj = "ProductShop Newsletter";
                        $mailhead = "From: $email\n";
                        reset ($HTTP_POST_VARS);
                        $mailbody = "Values submitted from web site form:\n";
                        while (list ($key, $val) = each ($HTTP_POST_VARS))
                        {
                        $mailbody .= "$key : $val\n";
                        }
                        mail($mailto, $mailsubj, $mailbody, $mailhead);
                        ?>
                        </BODY>
                        </HEAD>

                        George
                        George Fountakos
                        VodaHost
                        www.VodaHost.com
                        Your Website People
                        +1-302-283-3777 USA / Canada / International
                        (0044) 020 8816 8319 / United Kingdom

                        Comment


                        • #13
                          Hi George,

                          I have uploaded the following and it still comes up as N/A in senders email.
                          <HTML>
                          <HEAD>
                          <TITLE>Succesfully processed your order</TITLE>
                          </HEAD>
                          <BODY>
                          <H2>Thanks for your order!</H2>
                          <?PHP
                          $email = $HTTP_POST_VARS[email];
                          $mailto = "info@productshop.com.au";
                          $mailsubj = "ProductShop Newsletter";
                          $mailhead = "From: $email\n";
                          reset ($HTTP_POST_VARS);
                          $mailbody = "Values submitted from web site form:\n";
                          while (list ($key, $val) = each ($HTTP_POST_VARS))
                          {
                          $mailbody .= "$key : $val\n";
                          }
                          mail($mailto, $mailsubj, $mailbody, $mailhead);
                          ?>
                          </BODY>
                          </HEAD>

                          Why won't it work.
                          Lisa

                          Comment


                          • #14
                            Hi George,

                            I forgot to tell you about another problem
                            When I upload my index.php in FTP, I
                            1) Create a new folder in my remote files named index
                            2) I click and drag my index.php file from my root file across
                            3) When I open a fresh window and test my newsletter request, it comes up with error page 404.
                            4) I have gone to tutorials and viewed error messages in cPanel. Alittle bit confusing for me. Should I be doing something there?
                            Lisa

                            Comment


                            • #15
                              Look Lisa, you need to read what I sent you, your form is created wrong. It needs to look like this:

                              <HTML>
                              <HEAD>
                              <TITLE>Succesfully processed your order</TITLE>
                              </HEAD>
                              <BODY>
                              <H2>Thanks for your order!</H2>
                              <?PHP
                              $email = $HTTP_POST_VARS[email];
                              $mailto = "order@example.com";
                              $mailsubj = "Enter Your Subject Here";
                              $mailhead = "From: $email\n";
                              reset ($HTTP_POST_VARS);
                              $mailbody = "Values submitted from web site form:\n";
                              while (list ($key, $val) = each ($HTTP_POST_VARS))
                              {
                              $mailbody .= "$key : $val\n";
                              }
                              mail($mailto, $mailsubj, $mailbody, $mailhead);
                              ?>
                              </BODY>

                              You have modified your code wrong. Until it looks like the above with the appropriate email address inserted it will not work.
                              George Fountakos
                              VodaHost
                              www.VodaHost.com
                              Your Website People
                              +1-302-283-3777 USA / Canada / International
                              (0044) 020 8816 8319 / United Kingdom

                              Comment

                              Working...
                              X